青龙面板安装所有依赖

青龙面板脚本运行错误分析

青龙面板里脚本运行的常见错误有两种。

  1. 缺少依赖的错误

日志提示错误格式:Error: Cannot find module ‘xx’'xxxx' module not found

原因:青龙面板缺少相关的依赖。

  1. 缺少文件的错误

日志提示错误格式:Error: Cannot find module ‘./xx’

原因:大概率是拉库命令不完整,检查或重新复制完整命令进行拉库。

安装依赖

一键安装所有依赖:

这里用的github仓库QLDependency的脚本。

ssh连接你的机子,输入以下命令。

国内版:

1
docker exec -it qinglong bash -c "$(curl -fsSL https://ghproxy.com/https://raw.githubusercontent.com/FlechazoPh/QLDependency/main/Shell/QLOneKeyDependency.sh | sh)"

国外版:

1
docker exec -it qinglong bash -c "$(curl -fsSL https://raw.githubusercontent.com/FlechazoPh/QLDependency/main/Shell/QLOneKeyDependency.sh | sh)"

版本号 2.12+ 的新版本青龙安装失败请尝试:

1
docker exec -it qinglong bash -c "$(curl -fsSL https://raw.githubusercontent.com/FlechazoPh/QLDependency/main/Shell/XinQLOneKey.sh | sh)"

无代码添加方法

直接进入青龙面板依赖菜单,添加依赖,分拆选择<是>,即可批量添加,等待安装完成就行了。

1. Nodejs

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
crypto-js
prettytable
dotenv
jsdom
date-fns
MD5@1.3.0 
md5@2.x 
canvas
tough-cookie
tslib
ws@7.4.3
ts-md5
jsdom -g
jsrsasign
jsencrypt
jieba
fs
form-data
json5
global-agent
png-js
@types/node
require
typescript
js-base64
axios
moment
node-jsencrypt
node-rsa
node-fetch
qs
ds
yml2213-utils

2. Python3

1
2
3
4
5
6
7
8
requests
canvas
ping3
jieba
PyExecJS
aiohttp
redis
pycryptodome

3. Linux

1
2
3
4
5
6
--no-cache
build-base
g++
cairo-dev
pango-dev
giflib-dev

参考

https://blog.csdn.net/y19900113/article/details/127805099 https://blog.csdn.net/xiaojing_yu/article/details/124141113

0%